Yamaha Multifunction Gauge OUTBOARD Digital Speedometer Issues

Discussion in 'Boats, Motors, Trailers and Towing Rigs Forum' started by Hicksy12, May 26, 2020.

  1. Hicksy12

    Hicksy12 New Member

    Speedometer and fuel gauge screen has gone on OB 97 Yamaha 2 stroke. Wondering if anyone has had any luck replacing with an off brand gauge. I only need the fuel could go without speedometer.
     
  2. profisher

    profisher Well-Known Member

    I went with a seperate fuel guage 20 plus years ago. Its maybe a 2 inch round unit with a pointer needle and a light, has worked perfectly since installed. The speedo normally stops working because the pickup tube in the leg gets plugged with crap.
     
  3. Hicksy12

    Hicksy12 New Member

    Great, thanks. The screen seems to be the issue... Black streaks on top and bottom of screen and very light numbers appearing after winter storage. Think some moisture must have gotten in the unit...Did you have to re wire from the fuel tank? Or were you able to use the original wiring and connect at your dash?
     
  4. noluck

    noluck Well-Known Member

    i am sure i have one of those gauges, can you take a picture of it?
     
  5. profisher

    profisher Well-Known Member

    It was so long ago I don't remember...but I'm sure you would use same wires...wires from sending unit and power...maybe splice one from dash light switch as well. Biggest thing will be using a hole saw to cut into the dash to mount it. Noluck may have a better opton with a good used gauge..the liquid crystal does go in them over time, I have replaced my same Yamaha gauge once. SG Power ad some kicking around...took 3 home and found one of the three that worked perfect.
     
  6. Hicksy12

    Hicksy12 New Member

    upload_2020-5-27_12-35-25.png
     

    Attached Files:

  7. Fisherman Rob

    Fisherman Rob Well-Known Member

    Hey maybe that's why mine stopped working about a year ago. Will have to check that out.
     
  8. noluck

    noluck Well-Known Member

    i do not have that one
     
  9. pescador

    pescador Well-Known Member

    On a Yamaha the hole is the size of a small drill bit hole. They often get small pieces of wood in them and stop the speedo. I’ve had to clean mine several times. I just use a small piece of wire and push it into the hole.
     
  10. Fisherman Rob

    Fisherman Rob Well-Known Member

    Mine is not actually on the leg of the motor but mounted on the transom. It's got a little spinning paddle wheel, so perhaps not the same mechanism that you describe but I'll see if something is jammed into the sensor.
     

Share This Page